
DREAMWEAVER 4 
Web Site Development 
Software for Windows 

Kelly Smith, Northside ISD  
Department of Instructional Technology 

Problem Solving 

Com
m
unication Information Acquisition 

Fo
un

da
ti
on

s  



Dreamweaver 4 

Copyright 2001. Northside Independent School District and Kelly Smith. All Rights Reserved. 2

Table of Contents 
 

Introduction................................................................................................................4 

Preview of Things to Come .......................................................................................4 

The Workspace in Dreamweaver 4............................................................................5 

The Workspace ..........................................................................................................5 

The Menu Bar ............................................................................................................6 

The Document Window.............................................................................................6 

The Status Bar ............................................................................................................6 

The Floating Palettes..................................................................................................6 

The Objects Palette ....................................................................................................6 

The Property Inspector...............................................................................................7 

The Launcher .............................................................................................................7 

Guided Practice:  The Moderns Web Site .................................................................9 

Create a New Site (Structure & Organization) ..........................................................9 

Define the Site in Dreamweaver ................................................................................9 

Creating Your Home Page .......................................................................................10 

Formatting Text........................................................................................................10 

Adding a Background Color or Image.....................................................................11 

Create a Subpage......................................................................................................11 

Linking Pages Within Your Web Site .....................................................................12 

Previewing Your Pages............................................................................................12 

Defining HTML Styles ............................................................................................13 

Using HTML Styles .................................................................................................13 

Setting a Link to an E-Mail Address........................................................................13 

Adding a Horizontal Rule ........................................................................................14 

Adding Images .........................................................................................................14 

Adding a Table.........................................................................................................15 



Dreamweaver 4 

Copyright 2001. Northside Independent School District and Kelly Smith. All Rights Reserved. 3

Creating Links to URLs ...........................................................................................15 

Creating a Template from a Page.............................................................................16 

Using Templates ......................................................................................................17 

Activating Site Map Layout.....................................................................................18 

Setting Up Web Server Access ................................................................................19 

Uploading Your Site to the Web Server ..................................................................19 

Reusing Elements with the Library Feature ............................................................20 

Using Behaviors.......................................................................................................21 

Keywords Properties ................................................................................................23 

Description Properties..............................................................................................23 

Creating a Jump Menu .............................................................................................23 

Creating a Mailto: Form...........................................................................................25 

Editing HTML Source .............................................................................................28 

Creating and Using Frames......................................................................................29 

Create a Frameset.....................................................................................................29 

Saving the Frameset .................................................................................................30 

Assigning Names and Properties to Frames ............................................................30 

Setting Links in Frames ...........................................................................................30 

Working with Layers ...............................................................................................31 

Adding a Javascript for Password Protection ..........................................................32 

Making Global Changes to Links ............................................................................32 

Finding and Fixing Broken Links ............................................................................32 

Refresh Properties ....................................................................................................33 

Designing and Applying Cascading Style Sheets  (CSS)........................................34 

 



Dreamweaver 4 

Copyright 2001. Northside Independent School District and Kelly Smith. All Rights Reserved. 4

Introduction 
 
 
Macromedia Dreamweaver has clearly emerged as the top Web design program on 
the market.  Its ease of use and high-end features make it an ideal choice for 
professional Web designers, as well as for those who are relatively new to Web 
publishing.  Dreamweaver can help you with every aspect of Web development, 
from designing simple pages, to fixing broken links, to publishing your pages on 
the World Wide Web.  Dreamweaver can handle the simplest HTML, as well as 
some of the most complex features possible on the Web, such as frames, Dynamic 
HTML, styles, and layers.  It also integrates a powerful HTML text editor into its 
WYSIWYG design environment.  
 
 
 
 
 
Preview of Things to Come 
   
Visit these sites for a preview of two Web sites that you will create in this class!  
They were both created using the many, many, many features of Dreamweaver! 
 
 
http://www.nisd.net/mscmpww/Moderns_KellySmith 
 
http://www.nisd.net/mscmpww/Moderns_KellySmith/FramePractice/pw.htm 
(The password is webpro.) 
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The Workspace in Dreamweaver 4 
 
 
 

 
 
 
 
 
 
The Workspace 
• Appears automatically when you launch Dreamweaver 
• The place where you build your Web pages 
• Contains four basic components: the Menu Bar, the Document Window,  the 

Status Bar, and floating palettes 
 
 

Launcher 

Menu Bar 

Objects Palette 

Property Inspector 

Status Bar Launcher Icons 

Document Window 
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The Menu Bar 
• Provides access to all the features of Dreamweaver 
• Most, but not all, of the menu commands can be performed by using the 

buttons/icons on the floating palettes 
 
 
The Document Window 
• Displays text, images, and other elements in much the same way that a Web 

browser displays them 
• This is where you edit and design your pages 
• Looks like a blank page, but is really a simple bare-bones HTML file 
 
 
The Status Bar 
• Can be turned on or off in the View menu 
• Left end: shows HTML codes that indicate how elements on your page are 

formatted 
• Right end: contains shortcuts to all the features available in the Launcher.  

Hint:  Use the icons and close the Launcher so you will have a larger view of 
your Document Window. 

 
 
The Floating Palettes 
• Provide easy access to most of Dreamweaver’s features 
• You can drag them around to reposition them 
• You can close any or all of them if they are distracting  by clicking the palette’s 

Close box (X) 
• You can bring them back through the Window menu 
• There are three floating palettes:  Objects Palette, Property Inspector, Launcher 
 
 
The Objects Palette 
• Contains buttons for creating HTML objects, such as tables, images, forms, etc. 

(An object is anything you can put on an HTML page.) 
• There are seven subpalettes in the Objects Palette:  Common, Characters, 

Forms, Frames, Head, Invisibles, Special 
• Click the small arrow at the top right corner of the Objects Palette to switch 

between subpalettes 
• Drag borders or corners to resize 
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• Specify whether to display only the icons or the icons and their names in the 
Edit menu, Preferences command Under the category of general, you will see 
Object Panel. Click the down delta to change the preferences. 

 
 
The Property Inspector 
• Displays the properties of a selected element on the page (A property is a 

characteristic or attribute of HTML, such as the alignment of text or the size of 
a cell in a table.) 

• When you click an element, the Property Inspector changes to display the 
properties for that particular element 

• You can alter the properties of an element by changing the field values in the 
Property Inspector 

• Click the small arrow in the bottom right corner to see additional (advanced) 
attributes 

 
 
The Launcher 
Allows you to open dialog boxes to access:  Site features, the Assets, HTML Styles, 
Cascading Sytle Sheets (CSS), Styles, Behaviors, History, and the Code Source 
• Site 

 Lists all files and folders in a Web site 
 Helps you manage structure and organization of your site 
 Lets you access FTP capabilities to upload your site to the Web server 

• Assets 
 Lets you store items in a central place so that you can easily add them to 

multiple pages 
 Warning: only available if you have defined your site using the Site 

Definition dialog box 
• HTML Styles 

 “Styles” refers to a specific set of text attributes such as fontfaces, sizes, and 
formatting. 

 Enables you to store commonly used styles for easy access.  Dreamweaver 
calls these “H styles.”   

 H styles effect only one occurrence of the style – the place where you 
actually apply the style 

 Similar to, but much more limiting than, cascading style sheets 
• CSS  (Cascading Style Sheets) 

 Enables you to define styles and apply them to text or other elements on a 
page 
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 Makes it easy to create a consistent look and feel throughout your Web site 
 When you change a style all occurrences of that style will be updated in your 

document 
• Behaviors 

 A behavior is made up of a specified event that, when triggerred, causes an 
action 

 Behaviors are scripts, usually written in JavaScript, that you can apply to 
objects to add interactivity to your Web page 

• History 
 Keeps track of every action you take in Dreamweaver 
 Can be used to undo multiple steps at once, to replay steps, and to automate 

tasks 
• Code Source 

 Integrated HTML text editor 
 Changes made here automatically appear in the Document Window 

(WYSIWYG editor), and vice versa 
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Guided Practice:  The Moderns Web Site 
 

You are going to create a Web site about “The Moderns,”  three of the most 
famous writers that America has ever known. The Moderns are Ernest 
Hemingway, John Steinbeck, and Eudora Welty.  The Web site will address the 
personal life and literary works of each of the three authors. 
 
 
Create a New Site (Structure & Organization) 
1. Create a folder on your desktop named 

Moderns_YourName. 
2. Use Windows Explorer to create the file structure 

pictured here. 
3. Go to the following website and save all the images 

into the image folder: 
http://www.nisd.net/cmptecww/tutorial_images/photos.htm 
Right click on each image and choose save image. Navigate to your images 
folder and click save. 

 
 
Define the Site in Dreamweaver 
1. Launch Dreamweaver. 
2. Close all palettes except the Objects palette and the Properties palette.  

(Window menu) 
3. From the Site menu, choose the New Site command. 
4. Select the Local Info category on the left side of the dialog box. 
5. In the Site Name text box, type an appropriate name for your site (e.g The 

Moderns Web Site by Kelly Smith) 
6. Use the Browse button (looks like 

a folder) to select the Local Root 
Folder on your desktop that you 
created above (e.g. 
Moderns_KellySmith) 

7. Place a checkmark in the box next 
to Refresh Local Files List so 
that Dreamweaver will 
automatically update the list of all 
new pages that you add to your 
site. 

8. If you do not yet know the Web address for your site (after it is published to 
the Web server), leave the HTTP Address box blank. 
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9. Place a checkmark in the box next to Enable Cache for increased speed.  
10. Click OK, then close the Site window. 
 
 
Creating Your Home Page 
1. Click to insert your cursor at the top of the blank page in the Document 

Window. 
2. Type the following, allowing the text to wrap: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
3. Spell check your page:  Text menu, Check Spelling command. 
4. Title your page: Modify menu, Page Properties command. In the Title box, 

type The Moderns, then click OK.  (This title appears at the top of the 
browser window.) 

5. Save your page:  File menu, Save command.  Be sure to Save in the desktop 
folder where your site has been previously defined.  Name your file 
index.html. 

 
 
Formatting Text 
1. Select the text that you want to format. 
2. Use the Property Inspector fields to apply formatting.  (Note: You can also 

use the Text menu.) 
3. Format your home page according to these specifications: 

• Heading 1 for the title 
• Unordered List for the list of three names 
• Purple (#993399), bold “Thanks for visiting!” 

4. Re-save your page. 

The Moderns 
 
The Moderns are three of the most famous writers that America has ever known. The 
Moderns are Ernest Hemingway, John Steinbeck, and Eudora Welty.  This Web site 
will address the personal life and literary works of each of the three authors. Not only 
is their writing famous and exciting, but these authors led fascinating, active lives. 
The insight into life displayed in their stories leads the reader to appreciate these 
three writers for their humanity as well.   
 
Ernest Hemingway 
 
John Steinbeck 
 
Eudora Welty 
 
Send your comments to the author of this Web site.  Thanks for visiting! 
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Adding a Background Color or Image 
The background of your page can be a solid color or a wallpapered image.  The 
most important thing to remember about using an image is to save the image in the 
folder that you want to keep it in before you use it on your page. If you use an 
image and then move the image to a new location, you will break the link between 
the page and the image (i.e. you’ll see a broken or missing image icon).   
1. Background Color  (FYI only:  do not actually change the background color 

now!) 
• From the Modify menu, click Page Properties. 
• Click the color drop down box next to the word Background. 
• Use the eyedropper to select a color. (The default background color is 

white #FFFFFF.) 
• Click OK. 

2. Image Background (Do this) 
• From the Modify menu, click Page Properties. 
• Click the Browse button next to the Background Image box.  Navigate 

to where your image is saved.  Double click to select it (e.g. 
StainedGlass.gif) 

• Click OK. 
• Select all text (Ctrl-A), then click the Indent button in the Property 

Inspector one time. 
• Save your work 

 
 
Create a Subpage 
1. From the File menu, select the New command.  
2. From the  File menu, select the Save command.   

• Be sure to Save in the Hemingway folder of your site.   
• Name this file hemingwaybio.html. (Note: when saving web pages it is 

best to use one word names only; no spaces and all lowercase.) 
3. On the page: 

• Type “Ernest Hemingway” 
• Skip a couple of lines, then type “Back to The Moderns Homepage” 
• Title your page: Modify menu, Page Properties command. In the Title 

box, type Ernest Hemingway Biography. 
• Apply the StainedGlass Background Image, then click OK. 
• Indent the two lines of text using the Indent button in the Property 

Inspector. 
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Linking Pages Within Your Web Site 
This type of a link is also called an internal or relative link.  The most important 
thing to remember is to save your pages in the folders that you want to keep them 
in before you start setting links.  If you set a link and then move the page that you 
linked to a new location, you will break the link (i.e. it will no longer work).   
1. Select the text that you want to convert into a hypertext link. 
2. Use the Property Inspector field to create the link.  Click the Browse icon 

(looks like a folder) at the end of the Link text box.   
3. From the Select File dialog box, click the page to which you wish to link.   
4. Create links in your Moderns pages according to these specifications: 

• Link “Ernest Hemingway” in the unordered list on the home page to the 
hemingwaybio page. (You can switch back to the index page via the 
Taskbar.)  

• Link “Back to The Moderns Homepage” on the hemingwaybio page back 
to the index page. 

5. Re-save all pages (From the File menu, click the Save command). 
 
 
Previewing Your Pages 
Most Web design programs include some way of previewing your pages in a 
browser.  Dreamweaver takes this feature two steps farther by enabling you to 
check your work in a number of browsers and even test the compatibility of your 
pages in different versions of different browsers. 
1. Basic previewing:  From the File menu, select the Preview in Browser 

command, then click a browser’s name. 
2. Adding browsers to the list:  From the File menu, select the Preview in 

Browser command, then click Edit Browser List.  Use the plus sign to add 
browsers, if necessary. Navigate to the browser file. 

3. Test compatibility:  From the File menu, select Check Target Browsers.  
Select a specific browser version, then click the Check button.  A report is 
generated that lists any HTML features that you have used that the chosen 
browser does not support. 
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 Defining HTML Styles 
1. Click the Show HTML Styles button on the 

Launcher or the Status Bar. 
2. In the bottom right corner of the HTML 

Styles window, click the New Style 
button.(+) 

3. Name the new style (e.g. CenteredTitle) 
4. Generally, click the Apply to Paragraph 

radio button. 
5. Generally, click the Clear Existing Style 

When Applying radio button. 
6. Choose Font Attributes (e.g. purple color 

#993366, bold) 
7. Choose Paragraph Attributes (e.g. Heading 

1) 
8. Choose Alignment (e.g. centered) 
9. Click OK.  The new style is now listed with 

the existing HTML styles.  If you ever want to 
edit the style, click its name in the list. 

 
 
 
Using HTML Styles 
1. Select the text to format using a style (e.g. “Ernest Hemingway” on the 

hemingwaybio page). 
2. If the HTML Styles window is not already open, click the Show HTML 

Styles button on the Launcher or the Status Bar. 
3. Click to select a style from the list (e.g. CenteredTitle) 

 
 
Setting a Link to an E-Mail Address 
1. Select the text that you want to convert into a link (e.g. the word “author” 

near the bottom of your index page) 
2. From the Common Objects Palette, select the Insert E-mail Link button. 
3. In the E-mail box, type your e-mail address (ex. cmptec04@nisd.net) 
4. Click OK. 
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Adding a Horizontal Rule 
1. Position your cursor (e.g. underneath “Ernest Hemingway” title on the 

hemingwaybio page) 
2. From the Common Objects Palette, click the Insert Horizontal Rule 

button. 
3. If you wish, you may use the fields in the Property Inspector to alter the 

appearance of the rule (e.g. 80% width). 
 
 
Adding Images 
The most important thing to remember is to save your images in the folders that 
you want to keep them in before you start inserting them into your pages. If you 
insert an image and then move the image to a new location, you will break the link 
between the page and the image (i.e. you’ll see a broken or missing image icon).   
 
General Instructions: 
1. Open the page where you want to insert the image and position your cursor.  
2. From the Common Objects Palette, click the Insert Image button. 
3. Navigate to the folder where the image is saved. 
4. Double click the image to select it. 
5. Click the image to display its attributes in the Property Inspector.  You 

may change the field values to alter alignment, size, alternate text, link, 
border, etc. 

 
Add images to The Moderns site according to these specifications: 
 

• Insert the hemingway.jpg image underneath the title on the hemingwaybio 
page. 

• Enter the author’s name in the Alternate Text field for the image. 
• Center the image on the page by using the Align Center button in the 

“advanced” portion of the Property Inspector.  (You may have to click 
the little triangle in the bottom right corner of the Property Inspector to 
expand it.) 

• Insert StainedRule.gif on the line after “The Moderns” title in your index 
page. 

• Re-save all pages (From the File menu, click the Save command). 
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Adding a Table 
1. Create a blank line and position your cursor below the image on the 

hemingwaybio page. 
2. From the Common Objects Palette, click the Insert Table button. 
3. Make your selections for rows (3), columns (2), width (87%), border (leave 

default), cell padding (leave default),  and spacing (leave default).  NOTE: a 
border of zero is invisible. 

4. Select the two cells on the first row. Merge them using the Merges… button 
on the Property Inspector. 

5. Type the following text into the cells (bold row one): 
 

Follow these links to learn about the personal life and literary works of Ernest Hemingway! 
www.hemingwayhome.com www.lostgeneration.com/hrc.htm 
www.theatlantic.com/unbound/flashbks/hemingway.htm www.hemingway.org 

 
6. Select the entire table by clicking its outside border (handles will appear). 

Use the buttons in the Property Inspector to set an attractive table 
background color (Bg) and an attractive table border (Brdr) color. 

7. Re-save all pages (From the File menu, click the Save command). 
 
 
Creating Links to URLs 
This type of a link is also called an external or absolute link. 
1. Select the text that you want to convert into a hypertext link. 
2. Use the Property Inspector field to create the link. Copy the address and 

paste it into the link field.   NOTE:  You must type http:// to begin the URL! 
3. Convert the four Web addresses in the above table into links to URLs. 
4. Re-save all pages (From the File menu, click the Save command). 
NOTE:  It's possible that some of the URLs listed above no longer exist.  You may have to 
find and substitute other relevant links. 
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Creating a Template from a Page 
Dreamweaver provides design features that allow you to create the basic design of 
a page and then control which sections can and can’t be altered.  In our example, 
we have already designed the hemingwaybio page and we can now use it as a 
template for the other two authors’ biography pages.  
1. If it is not already open, open the page that you want to use as a template.  In 

this example, it is the hemingwaybio page. 
2. From the File menu, choose Save as Template. 
3. Use the drop down menu next to the Site text box to select a site (e.g. The 

Moderns by Kelly Smith). 
4. Type a name for the template in the Save As text box (e.g. authorpage). 

Click the Save button. 
5. All elements are “locked” by default.  You must make some areas “editable” 

for the template to be of any use.  For our example: 
• Select the “Ernest Hemingway” title.  From the Modify menu, select 

Templates, then click New Editable Region.  Name the editable region 
“title.” Click OK.   

• Select the picture of Ernest Hemingway. From the Modify menu, select 
Templates, then click New Editable Region.  Name the editable region 
“photo.” Click OK.   If the photo moves then click on the little button 
that says photo and cut the picture. Paste it back where it belongs. You 
cannot just click and drag the picture to the right location. 

• Select the entire table by clicking on its outside border (a 4-headed-arrow 
icon will appear).  From the Modify menu, select Templates, then click 
New Editable Region.  Name the editable region “table.”  Click OK.   
(The table may move!  If it does, cut it and paste it back in its original 
position.) 

• Re-save the template.  NOTE:  In our example, what’s NOT editable?  
Background image, horizontal rule, link back to the home page.  Also, 
you do not have to have an existing page from which to create a template.  
You can create a template from scratch by choosing the Templates 
command from the Window menu. 
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Using Templates 
1. From the File menu, select the New from Templates command. 
2. Open the authorpage template by double clicking its name. 
3. From the File menu, choose the Save As command.  Save this page in the 

Welty folder and name it weltybio.html. 
4. From the Modify menu, select Page Properties and re-title the page 

“Eudora Welty Biography.” 
5. Now replace the title, photo, and table regions with Eudora Welty’s name, 

photo, and table links.   
• Click the title, overtype the text with Eudora Welty. 
• Double click the photo, and select the welty.jpg image in your Images 

folder.  Type “Welty” for the Alt text. 
• Overtype Ernest Hemingway’s name in the table and replace it with 

Eudora Welty. 
• Totally delete the links that are already there. Replace the links with 

these URLs:   (some links may be outdated)  
http://www.olemiss.edu/depts/english/ms-writers/dir/welty_eudora 
http://mchip00.med.nyu.edu/lit-med/lit-med-
db/webdocs/webdescrips/welty102-des-.html 
http://www.galegroup.com/library/resrcs/womenhst/weltye.htm  
http://www.gsu.edu/~wwwewn/newsletter.htm  

6. Re-save this page. 
7. Repeat steps 1-6 for John Steinbeck. Use these URLs: (some links may be 

outdated)  
http://ocean.st.usm.edu/~wsimkins/rep.html  

 http://www.it.cc.mn.us/literature/steinbeck.htm 
http://www.steinbeck.org/index2.html  
http://www.sjsu.edu/depts/steinbec/srchome.html  

8. Now edit your index page and link the names in the bulleted list to the 
appropriate authors’ page. 

9. One last important step:  apply the template to the hemingwaybio page (the 
one that was used to create the authorpage template in the first place) 

• Open hemingwaybio 
• Modify menu > Template > Apply Template to Page > select the 

authorpage template 
10. Re-save all pages  
11. Preview in the browser to make sure everything works as expected! 
 
NOTE:  Now, when you make any changes to the template file (authorpage), 
all pages based on the template will be automatically updated!  Try it! 
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Activating Site Map Layout 
Dreamweaver includes a Site Map Layout to help you track your Web pages.  You 
can use this feature to automatically create a site map of all the pages in your Web 
site.  This will give you a visual reference to the hierarchy of your site and all of its 
links. 
1. From the Site menu, choose the Define Sites command. 
2. Click to select the name of your site, then click the Edit button. 
3. Select the Site Map Layout category on the left side of the dialog box. 
4. Use the Browse button (looks like a folder) at the end of the Home Page 

box to choose your home page.  Double click index.html. 
5. Click OK, then OK, then Done. 
 

 
 
6. The Site window, pictured above, displays the Site Map in the left part of 

the window.  If it does not, click the Site Map button (2nd one from the left 
on the toolbar) and choose Map and Files.  The right side of the window 
displays the directory structure of your site. 

7. NOTE:  Once the Site Map Layout has been activated, you can access the 
site map by clicking the Site Map icon in the Launcher or on the Status 
Bar. 

 
 
 
 



Dreamweaver 4 

Copyright 2001. Northside Independent School District and Kelly Smith. All Rights Reserved. 19

Setting Up Web Server Access 
Dreamweaver incorporates FTP capability so that you can easily upload your pages 
to a Web server.  You may prefer to use this feature instead of using a separate 
FTP program, such as WS_FTP. 
1. From the Site menu in the Site window, choose the Define Sites command. 
2. Click to select the name of your site, then click the Edit button. 
3. Select the Remote 

Info category on the 
left side of the dialog 
box. 

4. From the Server 
Access drop down list, 
select FTP. 

5. Type the FTP Host, 
Host Directory, 
Login, and Password 
provided by your 
instructor. 

6. Click OK.   
(Generally, if you are 
asked if you wish to 
create cache, click 
Create because it will be speedier.)  Click Done.  

7. Close the Site window. 
 
 
Uploading Your Site to the Web Server 
1. Click the Site Map icon in the Launcher or on the Status 

Bar. 
2. Click the Connect button.  If you are not already connected 

to the Internet, the Connect button should start up your dial-up connection.  
If it does not, you will need to establish your dial-up connection the way that 
you usually do, and then click the Connect button. 

3. After you have connected, click the Site Files button (1st from the 
left on the toolbar).   

4. IMPORTANT:  Right click your instructor’s name in the 
Remote Site (left half) side of the window so that you can create a new 
folder on the Web server.  Choose New Folder from the popup menu. Name 
this folder with the same name as the desktop folder which contains your 
Web site. 
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5. IMPORTANT:  Double click your new folder to open it on the remote 
site.  Now it is ready to receive your files. 

6. Simply drag your desktop file folder from the Local Folder (right half) side 
of the window into your newly created folder on the Remote Site.  (NOTE: 
If you get the question “Put entire site?” answer “Yes.”  If you get the 
question “Include dependent files?” answer “No” and checkmarck “Don’t 
ask me again.”  This will ensure that duplicate copies of files are not put on 
the server.) 

7. Click the Disconnect button when the transfer of files is complete. 
8. Close the Site window. 
IMPORTANT: After you have made changes to your site, you must be extremely 
careful when uploading change!  Be sure to drag your modified or new files and 
folders into the correct folders on the remote site.  If you are not careful you will 
overwrite files unintentionally that should not be overwritten! 
 
 
Reusing Elements with the Library Feature 
You can save any element as a Library item – for example, a logo or a navigation 
row of images and links.  You can insert that element on any page by simply 
dragging it from the Library to your pages.  Even better, you can change the 
element in the Library and then have Dreamweaver update all occurrences of the 
element throughout your site. 
1. Creating a Library Item 

• The simplest method is to first use the item on a page.  It will be 
automatically added to your assets.   

• Insert the logo.gif file in your index page, underneath the “Thanks for 
visiting line,” centered. 

• Click the Show Assets icon either from the Status Bar or the Launcher. 
2. Adding a Library Item to a Page 

• Open the page(es) on which you want to use a library item  (In our 
example, open the template.) 

• Drag the logo library item to the end of the “Back to The Moderns 
Homepage” line on the template. 

• Save the template. When you save it will prompt you to add the symbol 
to the other pages. Click the Update button.  
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Using Behaviors 
Dreamweaver gives you the ability to add interactivity to a page with the use of 
Behaviors.  Behaviors are scripts that are applied to a specific HTML tag.  These 
scripts are called by certain events (e.g. onClick, onMouseOver) that happen during 
the browser session.  We will use three of the most common Behaviors in our 
Moderns Web site:  Set Text Area, Swap Images, and Open Browser Window. 
 
1. The  “Set Text Area” Behavior:  This will display a custom message in the 

lower left corner of the browser. 
• Open the index page and select “Ernest Hemingway” in the unordered list. 
• Click the Show Behaviors icon on the Status Bar or from the Launcher. 
• Click the plus sign (+) to see a list of behaviors. 
• Choose Set Text, then click Set Text of Status Bar. 
• In the Message box, type “One of our favorite authors!” Click OK. 
• Repeat the sequence of steps for John Steinbeck (“Another favorite!”) and 

Eudora Welty (“We really like this one!”). 
• Re-save all pages (From the File menu, click the Save command). 
• Preview your site in the browser to see that the behaviors work as expected. 

 
2. The “Swap Images” Behavior:  This is often called a Rollover or a Mouseover. 
 

• Insert cats1.gif underneath the table on the hemingwaybio 
page.  In the image name box of the Property Inspector, type 
cats. Center the image. 

• With the image selected, click the Show Behaviors icon on 
the Status Bar or from the Launcher. 

• Click the plus sign (+) to see a list of behaviors. 
• Click Swap Image.  Choose cats from the list of named images.  
• Click the Browse button at the end of the Set Source to box.  Navigate to 

your Images folder and double click cats2.gif to select it.  Generally, 
Preload Images and Restore onMouseout should both be checked. 

• Click OK. 
• Re-save the page. 
• Preview your page in the browser to see that the behavior works as expected. 
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3. The “Open Browser Window” Behavior:  This behavior will open a new 
browser window in the top left corner of the current browser window.  We will 
attach this behavior to the logo on the index page. 
• First, we must create a new document that we want to display in the new 

browser window (File menu, New). 
 Type “Visit Instructional Technology at 

www.nisd.net/cmptecww/DeptWebSite!”   
 Format it in Heading 4 using the Property Inspector. 
 Select Page Properties from the Modify menu to change the 

Background color to purple #993399 and Text to white #FFFFFF.  Title 
the page “IT.” 

 Save the page as popupwin.htm in your Moderns desktop folder. 
• In your index page, click the logo to select it.   
• With the logo selected, click the Show Behaviors icon on the Status Bar or 

from the Launcher. 
• Click the plus sign (+) to see a list of behaviors. 
• Click Open Browser Window.  
• Click the Browse button at the end of the URL to Display box.  Navigate to 

your Moderns folder and double click popupwin.htm to select it.  Set the 
Window Width to 275 and the Window Height to 10. 

 
 
• Click OK. 
• Re-save the page. 
• Preview your page in the browser to see that the behavior works as expected. 
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Keywords Properties 
Many search-engine robots (programs that automatically browse the Web 
gathering information for search engines to index) read the contents of the 
Keywords META tag and use the information to index your pages in their 
databases. Some search engines put a limit on the number of keywords or 
characters they will index, and some ignore all keywords if you go beyond the 
limit. For this reason it's a good idea to limit your keywords to a few well-chosen 
words.  
1. From the Head Objects Palette, click the Insert Keywords button. 
2. Enter your keywords, separated by commas, in the field labeled Keywords. 

(e.g. Hemingway, Steinbeck, Welty) 
3. Click OK. 
4. Re-save the page. 
 
 
Description Properties  
Many search-engine robots read the contents of the Description META tag. Some 
use the information to index your pages in their databases, and some also display 
the information below the link to your page in the search results instead of the first 
few lines of your document. Some search engines put a limit on the number of 
characters they will index, so it's a good idea to limit your description to the fewest 
number of words possible.  
1. From the Head Objects Palette, click the Insert Description button. 
2. Enter your description (e.g. “Contains great links to sites about Ernest 

Hemingway, John Steinbeck, Eudora Welty”) 
3. Click OK. 
4. Re-save the page. 
 
 
Creating a Jump Menu 
A jump box is a popup menu that adds easy navigation to a Web site.  We are 
going to replace the unordered list of authors on the index page with a jump box. 
1. Open the index page and position your cursor underneath the paragraph. 
2. From the Forms Object Palette, click the Insert Jump Menu button. 
3. Type “Select an author”” in the Text field. 
4. Click the plus sign (+) to add a menu item for Ernest Hemingway. 
5. Type “Ernest Hemingway” in the Text field. 
6. Click the Browse button and choose the hemingwaybio page. 
7. Click the plus sign (+) to add menu items for Steinbeck and Welty. 
8. Place a check mark in the Select First Item After URL Change so that the 

menu resets to “Select an author.” 
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9. Click OK. 

 
10. Delete the unordered list from your page. 
11. Center the menu by clicking on it and then going to the text menu and 

chosing align, center. 
12.  Re-save the page and test it in the browser. 
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Creating a Mailto: Form 
Interactive forms provide a way to gather information from your visitor.  There are 
two categories of forms:  CGI and mailto:.  CGI (Common Gateway Interface) 
forms require a script, usually written in Perl, Java, C, or C++, to reside and run on 
the server.  With this type, when a  form is submitted from a Web page it triggers 
the CGI script on the server and process the incoming data.  Therefore, CGI forms 
require programming skills and the ability to put scripts on the server – two things 
that we are unable to do at this time.  Fortunately, we can make use of mailto: 
forms.  These forms look the same as CGI forms but their data is simply submitted 
directly to an e-mail address.  The data does not arrive in the greatest of formats, 
but it is useable. 
1. From the File menu, select the New comand. 
2. Save the page as quiz.htm. 
3. In Page Properties, title the page “The Moderns Quiz.” Apply the 

StainedGlass background image to the page. 
4. Type a title of “The Moderns Quiz” on the page and format it in the 

CenteredTitle HTML Style. 
5. Position your cursor, indented twice from the left margin, in the Document 

Window.  Reset the text to normal. 
6. From the Forms Objects Palette, click the Insert Form button. 
7. Use the Property Inspector to name the form (e.g. Quiz) and direct the 

submitted data to an e-mail address (e.g. mailto:cmptec04@nisd.net). 

 
8. Click inside the red form boundary, type “Your Name:” then click the Insert 

Text Field button. 
9. Use the Property Inspector to name the field Name, maximum length of 

30, on a single line. 

 
10. Click back inside the form and press <SHIFT> <ENTER> to make a single 

line break. 



Dreamweaver 4 

Copyright 2001. Northside Independent School District and Kelly Smith. All Rights Reserved. 26

11. Use the correct buttons on the Forms Objects Palette, along with 
appropriate text, to create the rest of the form. (SEE NEXT PAGE.)  Be 
sure to name each form object via the Property Inspector.    

12. When naming Radio Buttons give all the buttons for a question the same 
name. This way a person can only choose one multiple choice answer. With 
Checkboxes they can choose more than one answer so give each checkbox a 
unique name. 

13. Re-save the page and preview it in the browser. 
 
 
 
 
 
 
 
 
 
 

 
 

 
 

Insert Checkbox, Type in 
the answer where it says 
Checked Value. 

Insert Text FieldInsert Form

Insert Radio Button  
 Type the answer where 
it says Checked Value. 

Insert Button
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The Moderns Quiz 

 
Your Name:  

Summarize the childhood of John Steinbeck.  

Which author lived in Key West, Florida? 

Ernest Hemingway 

John Steinbeck 

Eudora Welty 

Which of these books were written by John Steinbeck? 

War and Peace 

The Grapes of Wrath 

Snow Falling on Cedars 

Of Mice and Men 

Submit Reset
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Editing HTML Source 
We need to add the Quiz in the Jump Menu on the index page.  This can be done 
by editing the HTML source. 
1. Select the Jump Box on the index page. 
2. Click the Show HTML Source icon from the Status Bar or the Launcher. 

  
3. Select and copy (Ctrl-C) the last <option value> tag, then paste the copy 

(Ctrl-V) between it and the </select> tag. 
4. Edit the tag so that it is: 

<option value = “quiz.htm”> Quiz </option> 
5. Re-save the page and preview it in the browser. 
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Creating and Using Frames 
There are pros and cons of using frames.  Frames add a wide range of design 
possibilities, but they can also create confusing navigation systems and can be 
frustrating for visitors to your site.  Nevertheless, many Web designers like 
frame layouts.  We will practice using frames and incorporate some of our 
existing files from “The Moderns” Web site. 

 
Create a Frameset 
1. Create a new folder in your Moderns desktop folder.  Name it 

FramePractice. 
2. Create a New page in Dreamweaver. 
3. From the Frames Objects Palette, click the Insert Left Frame button. 
4. Click inside the left portion of the frame 

• Type “The Moderns.”   
• Format it in Heading 3 using the Property Inspector. 
• Type the list of authors’ names (normal paragraph font), pressing 

ENTER after each name, underneath the title:  Ernest Hemingway, John 
Steinbeck, Eudora Welty.  Press ENTER twice and type “Home.” 

• Drag on the vertical dividing line to widen the left portion of the frame to 
accommodate the text all on one line. 

• Select Page Properties from the Modify menu to change the background 
color to dark blue #003399; Text, Links, Visited Links, and Active Links 
to white #FFFFFF. 

 

 
5.  Click the right portion of the frame.   

• Type this text: “The moderns are three of the most famous writers that 
America has ever known.  The moderns are Ernest Hemingway, John 
Steinbeck, and Welty. This Web site  will address the personal life and 
literary works of each of the three authors.  Not only is their writing 
famous and exciting, but these authors led fascinating, active lives. The 
insight into life displayed in their stories leads the reader to appreciate 
these three writers for their humanity as well.”  

• Format it in Heading 3, using the Property Inspector. 
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Saving the Frameset 
From the File menu, click the Save All Frames command. 

• First, save the frameset file. Navigate to the FramePractice folder and 
use ModernsFrame.htm as the filename. Press ENTER. 

• Second, save the right frame in the frameset. (Do you see that it has a 
striped border around it?)  Name it right.htm.  Press ENTER. 

• Third, save the left frame in the frameset. (Do you see that it has a striped 
border around it?)  Name it left.htm.  Press ENTER. 

 
 
Assigning Names and Properties to Frames 
1. From the Window menu, select the Frames command. 
2. Click the entire frameset in the Frames window. 

• From the Modify menu, select the Page Properties command.  Title the 
page “The Moderns” 

• Click OK. 
3. Click the right frame in the Frames window.   

• Note that it is named mainFrame.  You can change the name, but it is not 
necessary. 

• Set the Scroll to Auto. 
4. Click the left frame in the Frames window.   

• Note that it is named leftFrame.  You can change the name, but it is not 
necessary. 

• Set the Scroll to No. 
5. Close the Frames window. 
 
 
Setting Links in Frames 
1. Select the Ernest Hemingway text in the left frame.  Use the Property 

Inspector to create a link to the hemingwaybio page.  As the Target, select 
mainFrame. 

 
2. Select the John Steinbeck text in the left frame.  Use the Property Inspector 

to create a link to the steinbeckbio page.  As the Target, select mainFrame. 
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3. Select the Eudora Welty text in the left frame.  Use the Property Inspector 
to create a link to the weltybio page.  As the Target, select mainFrame. 

4. Select the Home text in the left frame.  Use the Property Inspector to create 
a link to the http://www.nisd.net.  As the Target, select _top to open the 
Northside page in a full Web browser window. 

5. Re-save all pages (File menu, Save) 
6. Preview your frameset in the browser to see that it works as expected. 
 
 
Working with Layers 
A layer is like a transparent box that can hold text, images and other elements.  
Layers can be repositioned, even overlapped, on a page to give you a lot of design 
control. 
1. Position your cursor underneath the text in the right frame of 

ModernsFrame. 
2. From the Insert Menu, choose the Layer command. 
3. Click the little tab in the layer’s top left corner to select the layer.  Use the 

Property Inspector to name the Layer ID “Hemingway.” 
4. Click to insert your cursor inside the layer. 
5. From the Common Objects Palette, click the Insert Image button.   
6. Select the hemingway image from your Images folder.  Resize the layer so 

that it “fits” the image.  Insert “Hemingway” as the Alt text in the Property 
Inspector. 

7. Drag the layer (with the little tab in the layer’s top left corner) to position it 
in the white space underneath the paragraph text.  

8. Repeat steps 2-6 for the steinbeck and welty images. Allow the images to 
overlap attractively. 

8. Re-save all pages (File menu, Save) 
9. Preview your frameset in the browser to see that it works as expected. 
 
NOTE 1:  To control the order of the layers (i.e. send to back, send to front, etc.), 
choose the Layers command from the Window menu.  Drag and drop the layer 
names into the desired order (1st in the list is the top layer; last in the list is the 
bottom layer). 
 
NOTE 2:  It is possible to design an entire Web page using layers, and then 
convert the layers into one big table.  This usually works well, if your layers do not 
overlap (a Layers palette option).  As with any use of layers, this technique gives 
you, the designer, better control over the layout of your page. (Modify > Covert > 
Layers to Table)  
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Adding a Javascript for Password Protection 
1. Create a new page and name it pw.htm. 
2. Click the Code Inspector View button on the Toolbar or from the 

Launcher. 
3. Launch Notepad, the Windows Accessory, and open the password.txt file 

(provided by your instructor). 
• This code is a Javascript that will authenticate a password before granting 

the visitor access to a Web page.  The correct password is webpro. 
• From the Edit menu, select the Select All command. 
• From the Edit menu, select the Copy command 
• Exit Notepad 

4. Position your cursor between the <head> tag and the <title> tag in the 
HTML source.  Press Ctrl-V to paste the copied text. 

5. From the File menu, select the Save command. (Save all of your files.) 
6. Close the HTML Source window. 
7. Preview your page in the browser to see that it works as expected.  (The 

URL for the Web site is now pw.htm, not ModernsFrame.htm) 
 
 
Making Global Changes to Links 
For your information, if you want to globally change a link to point to a new URL 
or to some other page in your site, you can use the Change Link Sitewide option 
to enter the new address and change every reference automatically.  NOTE:  There 
is no practice exercise. 
1. Click the Show Site icon on the Status Bar or the Launcher. 
2. Select the folder that represents your site in the Local Site portion (right 

side) of the window. 
3. From the Site menu, select the Change Link Sitewide command. 
4. Enter the “old” link and the “new” link in the text boxes, then click OK. 
 
 
Finding and Fixing Broken Links 
For your information, you can ask Dreamweaver to find broken links in your site. 
NOTE:  There is no practice exercise. 
 
1. From the Site menu, select Check Links Sitewide. 
2. The broken links will be displayed in the Link Checker window. 
3. Double click these broken links one at a time and then correct the link in the 

Property Inspector. 
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Refresh Properties  
For your information, you can use the Refresh element to specify that your page 
should refresh—by reloading the current page or going to a different one—
automatically after a certain amount of time.   NOTE:  There is no practice 
exercise. 
1. From the Head Objects Panel, click the Insert Refresh button. 
2. In the Delay box, type the time in seconds to wait before refreshing the 

page. To refresh the page immediately, enter 0 in this field. Note that leaving 
the field blank does not have the same effect as entering 0. 

3. Select and Action to specify whether to go to a different URL or to refresh 
the current page. To go to a different URL, click the folder icon to browse to 
and select the page to load. 

4. Click OK. 
5. Re-save the page. 
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Designing and Applying Cascading Style Sheets  (CSS)  
A style is a group of formatting attributes that controls the appearance of a range of 
text in a single document. A Cascading Style Sheet can be used to control several 
documents at once and includes all of the styles for a document. The advantage of 
using a CSS over an HTML style is that in addition to being linked to multiple 
documents, when a CSS is updated or changed, the formatting of all the documents 
that use that style sheet are automatically updated as well.  However, Cascading 
Style Sheets only work in 4.0 and later browsers. Earlier browsers ignore them. 
Also, unfortunately, they do not view in the same way in Internet Explorer and 
Netscape. 
1. When you begin, make sure that your cursor is somewhere in the right-most 

frame of ModernsFrame.htm. 
2. Click the Show CSS Styles button at the end of the Status Bar or from the 

Launcher. 
3. Click the pull-down menu button (right arrow next to the question mark) and 

choose New Style. 
• For Type, select Make Custom Style. 
• For Name, type .bodytext  (The beginning period is necessary because 

class names must begin with a period.) 
• Choose This Document Only 
• Click OK. 

4. Make choices in the Type Category, as shown below, for Font, Size, Style, 
and Color.  Do not click OK yet. 

RED
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5. Set the Text Align in the Block Category, as shown below, to justify. (If 
you clicked OK earlier, just double click on the bodytext icon in the CSS 
styles panel and then style definition window will open. 

 
6. Click OK to apply the changes to close the Style Definition window. 
7. You will see the changes right away if your cursor was positioned in the 

paragraph text.  If not, select the text and then click .bodytext in the CSS 
window.   

8. To apply a style to other documents, an external style sheet must be created, 
saved, and linked to from other documents.  The Trial Version of 
Dreamweaver does not allow external style sheets. 

 
 
 
 
 


