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Introduction 
 
Macromedia Flash is in industry-standard program for creating 
animated graphics for the Web and other uses. Flash movies can be 
found almost everywhere, and the player necessary for viewing Flash 
movies is now part of most browsers. 
 
Flash uses “Action Scripting” and layers, so that very sophisticated 
animations can be created. Action Scripting can also be used with 
Flash to create entire websites, such as the website of the German 
advertising firm Eye4U, which uses Flash in their online marketing 
products. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Flash and Flash Player 
 
It is important to remember that Flash and Flash Player are two 
separate programs. Flash is a professional program which is used to 
produce graphics and animations. It requires a license agreement 
before it can be installed on a computer. Flash Player, on the other 
hand, is a free program that only plays Flash movies. It is a part of 

A screenshot from the German company EYE4U’s Flash website (www.eye4u.com), 
in which a torrent of flowers spirals outward from the company logo. 
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many Web browsers, and it can be installed on a computer without a 
license agreement. 
 

 Flash Flash Player 

License needed? Yes No 

Purpose Create Flash 
movies 

Play Flash 
movies 

 
Because Flash Player is so commonly used, a short, simple Flash 
movie can be created and put it into a Web page without fear that it 
will cause problems for visitors. In this class, Dreamweaver will be 
used to insert the movie into a Web page. 

Uses of Flash 
 
Although it is used in sophisticated movies and websites, Flash can 
also be used in a classroom environment, where students can create 
simple animations and learn different ways of thinking creatively. In 
this course, Flash will be used to create an animated banner for a Web 
page. 
 

Terminology 
 
The following terms are used in this manual: 
 
Timeline – The timeline organizes the layers in a Flash movie. It is 
also where the flow of time is controlled. Just like in traditional movies, 
Flash movies divide time into frames. Every frame of each layer is 
shown in the Timeline. 
 
Stage – The Stage is the rectangular area where graphics are placed 
as part of creating Flash movies and other documents. 
 
Frame – A Frame is a unit of time in a Flash movie. All of the frames 
for each layer are shown in the Timeline. The default frame rate in 
Flash is 12 frames per second, so a 24-frame movie would last 2 
seconds. 
 
Keyframe – A Keyframe is used to define a change in an animation. 
In this course, keyframes are used to mark the starts and stops of 
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movement, and Flash is told to handle the frame-by-frame movements 
in between in a process called tweening. 
 
Tween – In Flash, an animator can define the starting and ending 
positions of an object, and Flash can control the movements of the 
object in between the two points. This is a motion tween. 
 
Selection Tool – Shown as a black arrow in the Tools Panel, the 
Selection Tool should be seen as the “default” tool in Flash. It is used 
to “click-and-drag” objects to move them around, to change the 
properties, of objects, and much more. 
 
F12 – The F12 key on the computer keyboard is pressed when a Flash 
user wants to see a preview of a Flash movie. 
 
Action Script – Action Scripts can be used to control many aspects of 
Flash documents and are used by advanced Flash authors. In this 
course, a simple Action Script is used to keep an animation from 
repeating over and over. 
 

Flash Versions 
 
This course was written using screenshots and instructions from Flash 
MX 2004, but these instructions will work with all recent versions of 
Flash. There may be some variations in menus and in the Tools Panel, 
but the essential features of Flash have not changed. 

Course Contents 
 
This session will cover the following: 
 

• Flash and Flash Player 
• What can I do with Flash? 
• Flash tools 
• Vector and bitmap images 
• Drawing in Flash 
• Layers 
• Creating a simple Flash movie 
• Introduction to Action Script 
• Export a Flash movie 
• Insert a Flash movie into a Web page 
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When to Use Flash? 
Sometimes Flash may not be the ideal program to use. Flash is at its 
best in creating movies with graphics that you created within Flash. 
Depending on the situation, another program – such as Javascript – 
may be a better choice for some projects. 
 
Use Flash 
 
• Web animations using images 

created in Flash 
• Animations for the Web with 

small, simple images 
imported into Flash 

 

Use Javascript 
 
• Web image slideshows using 

large or numerous images 
that were not created in 
Flash 

• Text animations – such as 
text “crawlers” – which have 
to be updated frequently. 

    
Free Javascript code that can be downloaded from 
www.dynamicdrive.com and other Web sites. Javascript image 
slideshows are faster to create, run faster over the Web, and are 
easier to update. 
 

Steps in Creating an Animated Flash Web Banner 
 
This course will cover the following steps for making a simple Flash 
movie: 
 

1. Setting up the Flash stage 
2. Import an image (an image could also be drawn in Flash) 
3. Add the school name and address 
4. Add the school motto 
5. Animate the mascot 
6. Animate the motto 
7. Animate the school name and address 
8. Making the animation STOP! 
9. Publish the movie! 
10. Insert the movie into a Web page! 
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Flash tools 
The Flash tool panel will probably look familiar to anyone who has used 
Photoshop, Photoshop Elements, or Fireworks. We'll be using a few of 
the tools to draw with. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Vector and Bitmap Images 
 
Most image editing programs, such as Fireworks, produce bitmap 
images. In a bitmap image, each individual pixel must be remembered 
in order for the image to be displayed correctly. If you have a 550 by 
400 pixel image (the default size of the Flash stage), that's 220,000 
individual points that must be stored, or as much as 660,000 bytes of 
storage space for a single image. If a movie was made up of this type 
of image, that file size would be too large for it to be viewed online. 
 
Vector graphics, on the other hand, store the image as a series of 
mathematical instructions. This can be more efficient, especially with a 
large image, as was described in the last paragraph. One of the 
greatest strengths of vector graphics is that they can be scaled up or 
down without affecting their appearance, and without affecting file 
size. Flash uses vector graphics. 
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Vector Graphics 
 
• Images created in Flash 
• Very efficient (small file size, 

even for large images) 
• The file tells the computer 

how to create the image, 
using a set of mathematical 
instructions 

• Can be made larger or 
smaller without distortion 

 

Bitmap Graphics 
 
• Images created with most 

image editing programs 
• Large images have large file 

sizes 
• The computer has to 

remember the color of every 
pixel in the image 

• Can be made smaller, but 
not larger, or the image will 
“pixelate” 

 
The Flash Workspace 
 
The Flash MX 2004 workspace is shown below. There may be some 
minor variations in other versions of Flash, but that should not pose a 
problem in this course. 
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Drawing in Flash 
 
The various drawing tools can be used to create simple images in 
Flash, which can then be animated. For this class, we’ll draw out a 
rectangle to use as the background for a school banner, then animate 
some images on top of it. 
 
  
 
 
 

1. Start Macromedia Flash, if you have not already done so. 
2. Select File > New and choose Flash Document. 
3. Spend a few minutes playing with the various drawing tools. 

Imagine using them in a classroom with students. Try this: 
 

• Use the Pencil Tool to draw a stick figure, a house, or some 
other simple objects. Try using the Straighten and Smooth 
options with the Pencil Tool. 

• Use the Oval Tool to try to draw a perfect circle. 
• Use the Brush Tool to do some painting! 

 
4. Use File > Save As to save the image as an .fla file, so that it 

can be edited later. 
5. Use File > Export > Export Image if you want to save in a 

format that can be used in other programs -- either a .gif 
(bitmap image) or a .swf (pronounced “swiff,” a Flash “movie” 
file).  

 
 

Creating an Animated Banner:  
Step 1 – Setting the Stage 
 
We’ll begin by changing the size of the Flash Stage (and the 
Document) to the approximate size of a Web page banner. We’ll then 
draw a rectangle on the stage to serve as a background for our 
banner. 
 

1. Select File > New and choose Flash Document. 
2. Choose the Selection Tool ( ). 
3. Click anywhere on the Stage. 

Hands-On Practice: Drawing Tools 
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4. In the Properties, click the button showing the Document Size 
(currently 550 x 400 pixels), to open the Document Properties 
window. 

5. Change the Document Properties to those in the image below, 
and click [OK]. 
 
 
 
 
 
 
 
 
 
 

6. Use the sliders on the side and bottom of the stage to reposition 
it so that you can see it. 

7. Choose File > Save As and Save the file as 
MurrayBanner.fla. 

 

Step 2 - Import an Image (Bring on the Mustelid!) 
 
Let’s add the school mascot to the banner. The school is Murray 
Elementary, and their mascot is the Mustelid. We’re going to import 
the image. 
 

1. Select File > Import > Import to Stage. 
2. Browse for the file mustelid.gif (provided by your instructor) 

and click [Open]. 
3. Click the Selection Tool ( ). Click the new image and drag it 

to about the position you see here. Fine movements can be 
made with the arrow keys. 
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4. In the Timeline, right-click the words Layer 1 (the layer for the 
mascot image) and choose Properties from the drop-down 
menu. 

5. In the Layer Properties window that appears, rename the layer 
Mascot. 

 

Step 3 – Add the School Name and Address 
 
We’re going to add the school name and address as a new layer, so 
that it can be animated separately from Murray the Mighty Mustelid. 
 

1. Look in the lower-left corner of the Timeline. The first icon there 
is the Insert Layer icon ( ). Click it to insert a layer for the 
school name. 
 
 
 
 
 
 
 
 
 
 

2. Select the Text Tool ( ) from the Tools. Click somewhere to the 
left of the mustelid and type the following: 
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To change font and size, just highlight the text and make the 
changes in the Properties. Any fonts and sizes can be used, but 
the following were used in this example:  
 

a. Font for the school name is Kristen ITC. 
b. Size for the school name is 34 points.  
c. Font for the address is Verdana. 
d. Size of the address is 15 points.  

 
3. Use the Selection Tool ( ) to position the text where you want 

it. Click the mustelid and drag it to a new location if needed. 
4. Right-click on Layer 2 (the layer for the school name and 

address) and choose Properties. 
5. In the Layer Properties window, rename the layer School 

Name. 
6. Use File>Save to save your work. 

 

Step 4 – Add the School Motto 
 
The school motto will be added as a third layer. All three layers will be 
animated separately. 
 

1. Click the Insert Layer icon ( ) to add a new layer. 
2. Choose the Text Tool ( ) from the Tools. Click below the 

mustelid, and type the following: 
 
 
 
 
 
 
 
 

3. Highlight the motto and format it by choose font, size and color 
from the Properties. The text shown above is Kristen ITC, size 
16, Bold face, and the color is a dark blue (#003366). 

4. Select the Selection Tool ( ) and use it move the motto to the 
desired position. 

5. Right-click on Layer 3 (the layer for the motto) and choose 
Properties. 
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6. In the Layer Properties window, rename the layer Motto. 
7. Save your work. 

 

Step 5 – Animate the Mascot 
 
Now, it’s time create an animation that allows the mascot to slide in 
from off-stage. The other two layers will be animated after Murray the 
Mustelid is finished. The banner should load quickly, to avoid annoying 
visitors to the website. At the standard rate of 12 frames per second, a 
2-second animation requires 24 frames. 
 
 
 
 
 
 
 
 
 
 

1. In the Timeline, make sure the Mascot layer is selected. Click in 
Frame 24 (a dark rectangle will appear in the frame). 

2. Select Insert>Timeline>Keyframe. The school name and 
motto will disappear. 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 

A frame rate of 12 frames per second is the default for Flash. If a different frame 
rate is desired, follow these steps: 
 

1. Choose the Selection Tool (black arrow) and click off the stage. 
2. In the Properties Panel, click the Size setting to open the Document 

Properties. 
3. Type in the desired Frame Rate and click [OK]. 
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3. This keyframe corresponds to the finished position of the 
mascot, at the end of a 2-second animation. Your Timeline and 
Stage should look something like this: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Click the first frame in the Mascot layer. With that frame 
selected, use the Selection Tool ( ) to move the mascot off 
the Stage, to the right, as shown below. We don’t need to add a 
keyframe, because there is already a keyframe in frame 1. 
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5. Now, we’ll add the animation. Right-click in the gray area 
between Frame 1 and Frame 24 in the Mascot layer. Choose 
Create Motion Tween. The area will change color, and an 
arrow will appear. 
 
 
 
 
 
 
 

6. Save your work. 
7. You can see a preview of your new movie by pressing the [F12] 

key. 
 

Step 6 – Animate the Motto 
 
We’re going to do something different with the motto. The mascot 
begins animating right at the start of the movie, and the school name 
will do the same. We’ll start the movement of the motto in the middle 
of the movie. It will move onto the Stage in the last half of the 
animation. 
 

1. Right-click in Frame 24 of the Motto layer in the Timeline. 
Choose Insert Keyframe. The motto should reappear on the 
Stage. This is the finishing position for the motto, at the end of 
the 2-second animation. 
 
 
 
 
 
 
 

2. Click in Frame 1 of the Motto layer. Use the Selection Tool ( ) 
to move the motto somewhere offstage. 

3. Right-click in Frame 12 of the Motto layer. Choose Insert 
Keyframe. 

4. Right-click in the gray area between Frame 12 and Frame 24 in 
the Motto layer. Choose Create Motion Tween. The area will 
change color, and an arrow will appear. 

5. Save your work. Preview by pressing the [F12] key. 
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Step 7 – Animate the School Name and Address 
 

1. Right-click in Frame 24 of the School Name layer in the Timeline. 
Choose Insert Keyframe. The school name and address should 
reappear on the Stage. This is the final position for this layer. 

2. Click in Frame 1 of the School Name layer. Use the Selection 
Tool ( ) to move the school name somewhere offstage. 

3. Right-click in the gray area between Frame 1 and Frame 24 in 
the School Name layer. Choose Create Motion Tween. The 
area will change color, and an arrow will appear. 

4. Save your work. Preview by pressing the [F12] key. 
 

Step 8 – Making the Animation STOP! 
 
Up to this point, when we’ve previewed our movie, it ran endlessly 
until we closed the browser. We want to make our banner appear and 
run through its animation just once. We’ll need to add an Flash Action 
Script to do this. 
 

1. Click Frame 24 in any of the three layers in the Timeline. 
2. Open the Actions Panel by selecting Window>Development 

Panels>Action. 
3. In the window on the left side of the Action Panel, choose Global 

Functions, then click Timeline Control. 
4. Double-click Stop. An Action Script will appear in the main 

window of the panel. 
 
 
 
 
 
 
 
 
 
 

5. Close the Actions Panel by 
right-clicking the box in the 
upper-right corner of the panel 
and choosing Close Panel. 

6. Save your work. 
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7. Preview your movie. It should now stop after one animation 
(two seconds). 

 

Step 9 – Publish the Movie! 
 
There is more than one way to publish a Flash movie. If you’re hand-
coding HTML, or using a simple editor, you’ll need to use the Publish 
feature to create both a “Swiff” (.swf) file and an HTML file with the 
code needed to activate your movie. 
 
Dreamweaver, on the other hand, makes it quite easy to insert a Flash 
.swf file into a Web page. We’ll export a .swf file and then use 
Dreamweaver to put it into a sample Web page. 
 

1. Select File>Export>Export Movie. 
2. Browse to the place where you want to save your Flash movie. 
3. Make sure that Flash Movie (*.swf) is selected from the Save 

as type drop-down menu. 
4. Name your movie MurrayBanner. 
5. Click [Save] to export your movie. 
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Step 10 – Insert the Movie into a Web Page! 
 
The instructor will provide a sample Web page to use for this exercise. 
You will be replacing an older, “flat” banner with the new, animated 
banner. 
 

1. Start Macromedia Dreamweaver. 
2. Open the file index.html (provided by instructor). 
3. Click the banner at the top of the page. 
4. Press the [Delete] key to remove it from the page. 
5. Select Insert>Media>Flash and browse to your new animated 

banner (MurrayBanner.swf). Press [OK]. 
 
 
 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
That’s it! You’ve successfully taken the first step into the world of 
Flash. 
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Notes: 
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